読者です 読者をやめる 読者になる 読者になる

opamp_sando's blog

クソザコが割りと適当なことを書くためにある備忘録です。あとたまに普通の日記も書きます

CMakeでQt5WidgetsConfig.cmakeが見つからないとか言われるとき

ちょっとしたミス。Qt5にかぎらずQt4でも同じ原因でエラーが起こりうるんだけど...
CMakeはqmakeのPATHでQtを探すようなので、正しいqmakeにPATHが通っていないとエラーになる。
なので前の記事でCMakeでQt5を使ったが、find_packageでこける人はQt5のqmakeにPATHが通っていない。

$ qmake --version
QMake version 3.0
Using Qt version 5.0.1 in /usr/local/Qt5/5.0.1/clang_64/lib

と、うちの環境ならこんな感じだが、QMake version 3.0くらいになってないとだめ。

Firefox ブラウザ無料ダウンロード